package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`batman|(\w+)`)
var str = `I am ironman and I was batman and I will be superman`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}