const regex = /,(.*?(?:,|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(.*?(?:,|$))', 'gm')
const str = `"name", "bob", "number", 16, "place", "somewhere" `;
const subst = `:$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);