re = /,(.*?(?:,|$))/m
str = '"name", "bob", "number", 16, "place", "somewhere" '
subst = ':$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result