const regex = /((?:(?<=))(f|fall|w|winter|s|spring|su|summer))\s*((?<!\d)(\d{4}|\d{2})(?!\d))/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?<=))(f|fall|w|winter|s|spring|su|summer))\\s*((?<!\\d)(\\d{4}|\\d{2})(?!\\d))', 'im')
const str = `fall 2018
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}