$re = '/((?:(?<=))(f|fall|w|winter|s|spring|su|summer))\s*((?<!\d)(\d{4}|\d{2})(?!\d))/im';
$str = 'fall 2018
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);