use strict;
my $str = 'Name: Tan
Email: pk.tan@my.rlb.com
Operator: Jeeva
Start Time: 07/01/2014 14:43:47
End Time: 07/01/2014 15:35:22
Product/Service: 5 Gallon Water Delivery
Phone: 62079991
Company: RL Bersepadu Sdn Bhd
Some other field won\'t work:scskcnskcnskcnk
Name: Tan
Email: pk.tan@my.rlb.com
Operator: Jeeva
Start Time: 07/01/2014 14:43:47
End Time: 07/01/2014 15:35:22
Product/Service: 5 Gallon Water Delivery
Phone: 62079991
See Company missing here: Above things are matching
';
my $regex = qr/^(?:Name|Email|Operator|Start Time|End Time|Product\/Service|Phone|(?:Company?)).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}