# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:Name|Email|Operator|Start Time|End Time|Product\/Service|Phone|(?:Company?)).*$"
test_str = ("Name: Tan\n"
"Email: pk.tan@my.rlb.com\n"
"Operator: Jeeva\n"
"Start Time: 07/01/2014 14:43:47\n"
"End Time: 07/01/2014 15:35:22\n"
"Product/Service: 5 Gallon Water Delivery\n"
"Phone: 62079991\n"
"Company: RL Bersepadu Sdn Bhd\n"
"Some other field won't work:scskcnskcnskcnk\n\n"
"Name: Tan\n"
"Email: pk.tan@my.rlb.com\n"
"Operator: Jeeva\n"
"Start Time: 07/01/2014 14:43:47\n"
"End Time: 07/01/2014 15:35:22\n"
"Product/Service: 5 Gallon Water Delivery\n"
"Phone: 62079991\n"
"See Company missing here: Above things are matching\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.