# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!common:)(?:([^\s\n]+)\s+){2}
/temp/gmix;t' <<< "common: \"mortalkombat_sonia_rules_abc,\" player: \"Mortal Kombat,\" 22-May-22
Test1 Test2 Type1 Type2 Type3 X Y HOR1 VER1 Data1 Error1
r1107 ab-1 abcr0201 222 22 -222 -22 -222 -22 2 2 Testing
r1106 ab-2 abcr0201 222 22 -222 -22 -222 -22 2 2 Testing
c377 ab-3 abcf0402 222 2 -222 -22 -222 -22 2 2 Testing
r632 ab-4 abcd0402 222 22 -222 -22 -222 -22 2 2 Testing"