import Foundation
let pattern = #"""
^(?!common:)(?:([^\s\n]+)\s+){2}
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
common: "mortalkombat_sonia_rules_abc," player: "Mortal Kombat," 22-May-22
Test1 Test2 Type1 Type2 Type3 X Y HOR1 VER1 Data1 Error1
r1107 ab-1 abcr0201 222 22 -222 -22 -222 -22 2 2 Testing
r1106 ab-2 abcr0201 222 22 -222 -22 -222 -22 2 2 Testing
c377 ab-3 abcf0402 222 2 -222 -22 -222 -22 2 2 Testing
r632 ab-4 abcd0402 222 22 -222 -22 -222 -22 2 2 Testing
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"temp"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)