package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-z][a-zA-Z0-9_]*`)
var str = `0utra_variavel3mSML
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}