#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?| (")((?:\\"|[^"])+)\1 | (')((?:\\'|[^'])+)\1 )"
Local $sString = "{if Server:GetPhpSelf == "/ind'ex.php"}" & @CRLF & _
"foo 'hhhh"hhh""hhh' plonk" & @CRLF & _
"foo "meep\"meep" plonk" & @CRLF & _
"foo 'meep\'meep' plonk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")