$re = '/(?| (")((?:\\\\"|[^"])+)\1 | (\')((?:\\\\\'|[^\'])+)\1 )/x';
$str = '{if Server:GetPhpSelf == "/ind\'ex.php"}
foo \'hhhh"hhh""hhh\' plonk
foo "meep\\"meep" plonk
foo \'meep\\\'meep\' plonk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);