using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(azureStorage)...................................................AccountName=).[^;]*";
string input = @"<add name=""azureStorage"" connectionString=""DefaultEndpointsProtocol=https;AccountName=mystorage;AccountKey=myKey"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}