re = /(?<=(azureStorage)...................................................AccountName=).[^;]*/
str = '<add name="azureStorage" connectionString="DefaultEndpointsProtocol=https;AccountName=mystorage;AccountKey=myKey" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end