$re = '/\'([^\'\\\\]*|(\\\\\')*)*\'/s';
$str = 'SELECT MAX(block_id) as max, COUNT(*) as cnt FROM (SELECT `cms_block`.`block_id`, `cms_block`.`content` FROM `cms_block` WHERE (content IS NOT NULL) AND (content LIKE (\'%data-content-type=\\"%\')) AND (`cms_block`.`block_id` > 0) ORDER BY `cms_block`.`block_id` ASC
LIMIT 50000) AS `t`';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);