# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"'([^'\\]*|(\\')*)*'"
test_str = ("SELECT MAX(block_id) as max, COUNT(*) as cnt FROM (SELECT `cms_block`.`block_id`, `cms_block`.`content` FROM `cms_block` WHERE (content IS NOT NULL) AND (content LIKE ('%data-content-type=\\\"%')) AND (`cms_block`.`block_id` > 0) ORDER BY `cms_block`.`block_id` ASC\n"
" LIMIT 50000) AS `t`")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.