re = /(?<=[A-Za-z0-9])\W(?=[A-Za-z0-9])/m
str = 'American Football
Mini Golf
AR/ VR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end