using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:(?<!<scr>).)*<scr>(?:(?!<scr>).)*)$";
string input = @"aa<scr>aaa<scr>aaa";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}