$re = '/^((?:(?<!<scr>).)*<scr>(?:(?!<scr>).)*)$/';
$str = 'aa<scr>aaa<scr>aaa';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);