package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d*)(.*?)-\s(.*?)\s(.*)`)
var str = `2014 Blah - Blah Blah Blah Blah-Blah Blah`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}