re = /(\d*)(.*?)-\s(.*?)\s(.*)/
str = '2014 Blah - Blah Blah Blah Blah-Blah Blah'
# Print the match result
str.match(re) do |match|
puts match.to_s
end