package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+(?:\.\d+)*) (\w+(?: \w+)*)`)
var str = `1.6.1 Members................................................................ 12
1.6.2 Accessibility.......................................................... 13
1.6.3 Type parameters........................................................ 13`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}