import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+(?:\\.\\d+)*) (\\w+(?: \\w+)*)";
final String string = "1.6.1 Members................................................................ 12\n"
+ "1.6.2 Accessibility.......................................................... 13\n"
+ "1.6.3 Type parameters........................................................ 13";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}