const regex = new RegExp('(?=((?<!\\.\\s|^)(?:[A-Z][a-z]+)))', 'g')
const str = `This study was aimed Javier Arturo at designing production of Moreno isoeugenol and vanillin from eugenol of clove leaf oil and analyzing the potential product development financially. The specific objectives of this research work are: 1. Identify the isoeugenol and vanillin. 2. Model simulation of process design of isoeugenol and vanillin. 3. Study on financial feasibility and added value. This research is expected to provide maximum economic potential of eugenol to enhance the added value of clove leaf oil. The results showed that the FTIR and NMR products confirmed that isoeugenol and vanillin present in the synthesized product were identical to the reference standards.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}