$re = '/(?=((?<!\.\s|^)(?:[A-Z][a-z]+)))/';
$str = 'This study was aimed Javier Arturo at designing production of Moreno isoeugenol and vanillin from eugenol of clove leaf oil and analyzing the potential product development financially. The specific objectives of this research work are: 1. Identify the isoeugenol and vanillin. 2. Model simulation of process design of isoeugenol and vanillin. 3. Study on financial feasibility and added value. This research is expected to provide maximum economic potential of eugenol to enhance the added value of clove leaf oil. The results showed that the FTIR and NMR products confirmed that isoeugenol and vanillin present in the synthesized product were identical to the reference standards.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);