const regex = /^(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\\.(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\\.(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\\.(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])$', 'gm')
const str = `0.0.0.0
10.0.0.1
127.0.0.1
169.254.0.0
172.20.255.255
192.168.0.1
255.255.255.255
-1.0.0.0
255.255.255.256
255.255.256.255
255.256.255.255
256.255.255.255
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}