$re = '/^(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:[01]?[0-9]{1,2}|2[0-4][0-9]|25[0-5])$/mx';
$str = '0.0.0.0
10.0.0.1
127.0.0.1
169.254.0.0
172.20.255.255
192.168.0.1
255.255.255.255
-1.0.0.0
255.255.255.256
255.255.256.255
255.256.255.255
256.255.255.255
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);