package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+-){1}FileName-(.+-){2}`)
var str = `data-FileName-author-data-`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}