$re = '/(.+-){1}FileName-(.+-){2}/';
$str = 'data-FileName-author-data-';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);