import re
regex = re.compile(r"^[a-z][a-z0-9]*(?:([-_])[a-z0-9]+(?:\1[a-z0-9]+)*)?$", flags=re.MULTILINE)
test_str = ("foo\n"
"foo-bar\n"
"foo_bar\n"
"foo-bar-baz\n"
"foo_bar_baz\n\n"
"= passed (but I don't want it to)\n"
"foo-bar_baz_qux\n"
"foo_bar-baz-quz")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")