import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Art\\.\\s*(?P<artikel>\\d+)\\s*\n"
+ "(?:Abs\\.\\s*(?P<absatz>\\d+))?\n"
+ "[^()]*?\n"
+ "(?P<gesetz>\\b[A-Z][A-Za-z]*[A-Z]\\b)";
final String string = "Beim angefochtenen Entscheid handelt es sich um einen Rückweisungsentscheid.\n"
+ "Darin wird die von der Staatsanwaltschaft verfügte Einstellung des Strafverfahrens\n"
+ "aufgehoben und die Sache an die Staatsanwaltschaft zurückgewiesen\n"
+ "zur Weiterführung und Ergänzung der Untersuchung. Es handelt sich um einen\n"
+ "Zwischenentscheid, der das Verfahren nicht abschliesst.\n"
+ "Bei blossen Rückweisungsentscheiden fehlt es in der Regel an einem nicht wieder\n"
+ "gutzumachenden Rechtsnachteil im Sinne von Art. 93 Abs. 1 lit. a BGG. Es\n"
+ "muss sich um einen Nachteil rechtlicher Natur handeln. Ein solcher liegt nur\n"
+ "vor, wenn er auch durch einen für den Beschwerdeführer günstigen späteren\n"
+ "End- oder anderen Entscheid nicht mehr behoben werden kann (BGE 141 IV\n"
+ "289 E. 1.1-1.2 S. 291; 137 IV 172 E. 2.1 S. 173 f.). In der blossen Verlängerung\n"
+ "oder Verteuerung des Verfahrens liegt grundsätzlich kein Nachteil im Sinne\n"
+ "von Art. 93 Abs. 1 lit. a BGG (BGE 133 V 477 E. 5.2.1 S. 483; 120 Ib 97\n"
+ "E. 1c S. 100; 116 Ib 344 E. 1c S. 347 f.). Im angefochtenen Entscheid wird\n"
+ "das weitere Vorgehen der Staatsanwaltschaft auch nicht in der Weise festgelegt,\n"
+ "dass ihr für den Abschluss der Untersuchung keinerlei Entscheidungsspielraum\n"
+ "mehr zustünde. Insbesondere hält die Vorinstanz eine allfällige Einstellung nach\n"
+ "erfolgter Ergänzung der Untersuchung nicht für ausgeschlossen. Zwar macht der\n"
+ "Beschwerdeführer geltend, bei einer Gutheissung der Beschwerde könne sofort\n"
+ "ein Endentscheid herbeigeführt werden. Nach der Praxis des Bundesgerichtes\n"
+ "ist Art. 93 Abs. 1 lit. b BGG jedoch im Strafprozess im Allgemeinen nicht\n"
+ "anwendbar (vgl. BGE 141 IV 284 E. 2 S. 286; 289 E. 1.1 S. 291).\n"
+ "Diese verfahrensrechtlichen Fragen brauchen im vorliegenden Fall nicht weiter\n"
+ "vertieft zu werden. Selbst wenn die Beschwerde unter dem Gesichtspunkt von\n"
+ "Art. 93 Abs. 1 BGG zulässig wäre, erwiese sie sich, wie aus den nachfolgenden\n"
+ "Erwägungen ergeht, jedenfalls als unbegründet. Ebenso kann offen bleiben, ob\n"
+ "und inwieweit die Beschwerde (mit beiläufigen Hinweisen auf einige Bestimmungen\n"
+ "der StPO) überhaupt gesetzeskonform substanziiert erscheint (Art. 42\n"
+ "Abs. 2 Satz 1 BGG).\n"
+ "4\n"
+ "2.\n"
+ "Die Vorinstanz erwägt zusammengefasst Folgendes: Die Diagnose des beschwerdeführenden\n"
+ "Hausarztes vom Morgen des 14. Dezember 2015 habe sich (gemäss\n"
+ "Gutachten des IRM) nachträglich als falsch erwiesen. Bei umgehender Einweisung\n"
+ "in ein geeignetes Spital hätte die Patientin eine statistische Überlebenschance\n"
+ "von ca. 75 % (bei einem Mortalitätsrisiko von 25 %) gehabt. Eine strafbare\n"
+ "fahrlässige Tötung lasse sich daraus nur dann ableiten, wenn das Verhalten des\n"
+ "Beschwerdeführers nicht mehr als vertretbar erschiene und daher den objektivierten\n"
+ "Regeln der ärztlichen Kunst nicht genügen würde. Dabei handle es sich\n"
+ "primär um eine medizinische Fachfrage. Die Einstellung der Strafuntersuchung\n"
+ "gegen den Beschuldigten sei nur dann bundesrechtskonform, wenn beim jetzigen\n"
+ "Aktenstand eine adäquat-kausale ärztliche Sorgfaltspflichtverletzung bereits klar\n"
+ "und eindeutig verneint werden könnte.\n"
+ "Bei der vorliegenden medizinischen Expertise handle es sich um einen Obduktionsbericht\n"
+ "nach einem aussergewöhnlichen Todesfall (Art. 253 Abs. 3 StPO).\n"
+ "Ein spezifisches medizinisches Gutachten (im Sinne von Art. 182 ff. StPO)\n"
+ "zu Fragen der gebotenen Behandlung durch den Hausarzt habe die Staatsanwaltschaft\n"
+ "bisher nicht eingeholt. Zwar verneine der Obduktionsbericht beiläufig\n"
+ "eine Verletzung der ärztlichen Sorgfaltspflicht. Die betreffenden Abklärungen\n"
+ "seien jedoch ungenügend.\n"
+ "Es erscheine bereits fraglich, ob Ausführungen zur Behandlung des Hausarztes\n"
+ "in einem Obduktionsbericht zulässig bzw. sinnvoll sind. Jedenfalls habe die\n"
+ "Staatsanwaltschaft dem IRM diesbezüglich keine ausreichend präzisen Gutachtensfragen\n"
+ "gestellt, wie sie das Gesetz (Art. 184 Abs. 2 lit. c StPO) vorschreibe.\n"
+ "Aber auch inhaltlich überzeugten die Ausführungen des IRM zur Diagnose und\n"
+ "Behandlung durch den Hausarzt nicht. Die verfahrensleitende Staatsanwältin\n"
+ "habe in einer bei den Akten liegenden E-Mail vom 15. Dezember 2015 (an die\n"
+ "für den Fall zuständigen Mitarbeiter der Kantonspolizei) erwähnt, dass gemäss\n"
+ "der telefonischen Auskunft einer Ärztin des IRM die im Polizeirapport über den\n"
+ "aussergewöhnlichen Todesfall beschriebenen Rückenschmerzen ein “typisches\n"
+ "Anzeichen für eine Aortendissektion” gewesen seien. Dieselbe Ärztin des IRM,\n"
+ "welche anschliessend den Obduktionsbericht mitverfasst habe, habe sinngemäss\n"
+ "auch geäussert, dass “jeder Hausarzt” dies hätte “wissen müssen”. Davon sei im\n"
+ "Obduktionsbericht auffälligerweise nicht mehr die Rede.\n"
+ "Unklar sei sodann die im Obduktionsbericht getroffene Unterscheidung zwischen\n"
+ "einem “Diagnosefehler” und einem “nachvollziehbaren Diagnoseirrtum”.\n"
+ "Inwiefern hier ein ärztlicher Sorgfaltsfehler vorliege oder nicht, werde vom IRM\n"
+ "nicht nachvollziehbar dargelegt. Ebenso wenig werde erklärt, inwieweit das\n"
+ "Verhalten des Hausarztes vor dem spezifischen Hintergrund sorgfaltskonform\n"
+ "erscheinen könnte, dass die heftig und plötzlich auftretenden Schmerzen der\n"
+ "Patientin offenbar keinerlei medizinische “Vorgeschichte” gehabt hätten, sondern\n"
+ "“aus heiterem Himmel” aufgetreten seien. Die relevanten offenen Fragen seien\n"
+ "von einem medizinischen Experten zu klären.\n"
+ "5\n"
+ "Am Problem vorbei gingen die Ausführungen im Obduktionsbericht, wonach\n"
+ "die von der privaten Beschwerdegegnerin nachträglich als geboten reklamierten\n"
+ "Zusatzabklärungen in einer Hausarztpraxis gar nicht hätten vorgenommen werden\n"
+ "können. Vielmehr stelle sich die Frage, ob für den Beschuldigten aus medizinischer\n"
+ "Sicht objektiv Anlass bestanden hätte, die Patientin zur weiteren Abklärung\n"
+ "und Behandlung sofort in ein geeignetes Spital einzuweisen. Ferner enthalte der\n"
+ "Obduktionsbericht keine näheren Angaben zur Schwere der Aortendissektion am\n"
+ "Morgen des 14. Dezember 2015 bzw. zum konkreten Mortalitätsrisiko im Falle\n"
+ "einer sofortigen Spitaleinweisung. Ohne weitere Abklärungen sei eine Einstellung\n"
+ "der Untersuchung nicht zulässig. Die Art der Weiterführung der Untersuchung\n"
+ "(nach erfolgter Rückweisung) bleibe im Übrigen der Staatsanwaltschaft überlassen.\n"
+ "3.\n"
+ "Der Beschwerdeführer macht geltend, die Staatsanwaltschaft habe ihren Auftrag\n"
+ "an das IRM korrekt erteilt. Im Obduktionsbericht werde durch “den Gutachter\n"
+ "des IRM” absolut schlüssig dargelegt, dass ihm, dem Beschwerdeführer, kein\n"
+ "ärztliches Fehlverhalten zur Last gelegt werden könne. Die gegenteiligen Ausführungen,\n"
+ "welche eine Ärztin des IRM angeblich telefonisch gegenüber der\n"
+ "Staatsanwältin gemacht habe, seien weder substanziiert noch begründet. Die diesbezügliche\n"
+ "E-Mail der Staatsanwältin vom 15. Dezember 2015 sei nichtssagend\n"
+ "und bedeutungslos. Die im Obduktionsbericht verwendeten Begriffe Diagnoseirrtum\n"
+ "und Diagnosefehler müssten weder ausgelegt noch definiert werden.\n"
+ "Allfällige Bluttests am Morgen des 14. Dezember 2015 hätten “nichts gebracht”\n"
+ "bzw. wären sogar fahrlässig gewesen. Eine ausreichende Infrastruktur bzw.\n"
+ "Geräte zur Diagnose einer beginnenden Aortendissketion seien ihm als Allgemeinpraktiker\n"
+ "und Hausarzt nicht zur Verfügung gestanden. Selbst bei einer\n"
+ "sofortigen Einlieferung in ein geeignetes Spital wären die Überlebenschancen der\n"
+ "Patientin sehr gering gewesen. Neue Erkenntnisse (über das von der Vorinstanz\n"
+ "geforderte medizinische Gutachten) seien nicht zu erwarten. Ein Zusatzgutachten\n"
+ "sei gemäss Art. 189 StPO nur zu erstellen, wenn der Obduktionsbericht unvollständig,\n"
+ "unklar oder widersprüchlich wäre oder wenn Zweifel an seiner Richtigkeit\n"
+ "bestünden. Dies sei hier jedoch nicht der Fall. Die Anschuldigungen der privaten\n"
+ "Beschwerdegegnerin fänden keine objektive Bestätigung im Untersuchungsergebnis,\n"
+ "weshalb (im Sinne von Art. 319 StPO) auch kein hinreichender Tatverdacht\n"
+ "erstellt sei.\n"
+ "4.\n"
+ "4.1. Bestehen bei einem Todesfall Anzeichen für einen unnatürlichen Tod, insbesondere\n"
+ "für eine Straftat, so ordnet die Staatsanwaltschaft zur Klärung der\n"
+ "Todesart eine Legalinspektion durch eine sachverständige Ärztin oder einen\n"
+ "6\n"
+ "sachverständigen Arzt an (Art. 253 Abs. 1 StPO). Bestehen nach der Legalinspektion\n"
+ "Hinweise auf eine Straftat, so ordnet die Staatsanwaltschaft die\n"
+ "Sicherstellung der Leiche und weitere Untersuchungen durch eine rechtsmedizinische\n"
+ "Institution, nötigenfalls die Obduktion an (Art. 253 Abs. 3 StPO).\n"
+ "In der Untersuchung klärt die Staatsanwaltschaft den Sachverhalt tatsächlich und\n"
+ "rechtlich so weit ab, dass sie das Vorverfahren abschliessen kann (Art. 308 Abs. 1\n"
+ "StPO). Sie zieht eine oder mehrere sachverständige Personen bei, wenn sie nicht\n"
+ "über die besonderen Kenntnisse und Fähigkeiten verfügt, die zur Feststellung oder\n"
+ "Beurteilung des relevanten Sachverhalts erforderlich sind (Art. 182 StPO). Die\n"
+ "Anordnung und Erstellung des Gutachtens richtet sich nach den Bestimmungen\n"
+ "von Art. 183-189 StPO. Die Fragen an die sachverständigen Personen sind\n"
+ "präzise zu formulieren (Art. 184 Abs. 2 lit. c StPO). Die Verfahrensleitung lässt\n"
+ "das Gutachten ergänzen oder verbessern oder bestimmt weitere Sachverständige,\n"
+ "wenn das Gutachten unvollständig oder unklar ist, mehrere Sachverständige in\n"
+ "ihren Ergebnissen erheblich voneinander abweichen, oder wenn Zweifel an der\n"
+ "Richtigkeit des Gutachtens bestehen (Art. 189 Abs. 1 lit. a-c StPO).\n"
+ "Erachtet die Staatsanwaltschaft die Untersuchung als vollständig, so erlässt\n"
+ "sie einen Strafbefehl oder kündigt den Parteien schriftlich den bevorstehenden\n"
+ "Abschluss an und teilt ihnen mit, ob sie Anklage erheben oder das Verfahren\n"
+ "einstellen will (Art. 318 Abs. 1 StPO).\n"
+ "Die Staatsanwaltschaft verfügt die vollständige oder teilweise Einstellung des\n"
+ "Verfahrens, wenn kein Tatverdacht erhärtet ist, der eine Anklage rechtfertigt,\n"
+ "oder wenn kein Straftatbestand erfüllt ist (Art. 319 Abs. 1 lit. a und b StPO). Sie\n"
+ "erhebt beim zuständigen Gericht Anklage, wenn sie aufgrund der Untersuchung\n"
+ "die Verdachtsgründe als hinreichend erachtet und keinen Strafbefehl erlassen kann\n"
+ "(Art. 324 Abs. 1 StPO). Wer fahrlässig den Tod eines Menschen verursacht, wird\n"
+ "mit Freiheitsstrafe bis zu drei Jahren oder Geldstrafe bestraft (Art. 117 StGB).\n"
+ "Ein solches Vergehen kann auch durch pflichtwidriges Untätigbleiben begangen\n"
+ "werden. Pflichtwidrig untätig bleibt, wer die Gefährdung oder Verletzung eines\n"
+ "strafrechtlich geschützten Rechtsgutes nicht verhindert, obwohl er aufgrund\n"
+ "seiner Rechtstellung dazu verpflichtet ist (Art. 11 Abs. 1-2 StGB).\n"
+ "4.2. Der Grundsatz “in dubio pro duriore” fliesst aus dem Legalitätsprinzip (Art.\n"
+ "5 Abs. 1 BV und Art. 2 Abs. 1 StPO i.V.m. Art. 319 Abs. 1 und Art. 324\n"
+ "Abs. 1 StPO; BGE 138 IV 86 E. 4.2 S. 91; 186 E. 4.1 S. 190; je mit Hinweisen).\n"
+ "Er bedeutet, dass eine Einstellung durch die Staatsanwaltschaft grundsätzlich\n"
+ "nur bei klarer Straflosigkeit bzw. offensichtlich fehlenden Prozessvoraussetzungen\n"
+ "angeordnet werden darf. Bei der Beurteilung dieser Frage verfügen die\n"
+ "Staatsanwaltschaft und die Vorinstanz über einen gewissen Spielraum, den das\n"
+ "Bundesgericht mit Zurückhaltung überprüft. Anklage ist zu erheben (sofern die\n"
+ "Erledigung mit einem Strafbefehl nicht in Frage kommt), wenn eine Verurteilung\n"
+ "wahrscheinlicher erscheint als ein Freispruch (BGE 138 IV 86 E. 4.1.1 S. 90 f.;\n"
+ "186 E. 4.1 S. 190; 137 IV 219 E. 7.1-7.2 S. 226 f.). Falls sich - nach gesetzeskon-\n"
+ "7\n"
+ "former ausreichender Untersuchung - die Wahrscheinlichkeiten eines Freispruches\n"
+ "oder einer Verurteilung in etwa die Waage halten, drängt sich in der Regel,\n"
+ "insbesondere bei schweren Delikten, ebenfalls eine Anklageerhebung auf (BGE\n"
+ "138 IV 86 E. 4.1.2 S. 91; 186 E. 4.1 S. 190). Im vorliegenden Fall geht es\n"
+ "noch nicht darum, ob Anklage zu erheben sei, sondern erst um die Frage, ob\n"
+ "anstelle der Einstellung die Untersuchung weiterzuführen sei; auch dies ist eine\n"
+ "strafprozessuale Ausprägung des Grundsatzes “in dubio pro duriore”.\n"
+ "5.\n"
+ "Der Vorinstanz ist darin beizupflichten, dass der Sachverhalt nicht in der Weise\n"
+ "ausreichend abgeklärt wurde, dass hier bereits eine Einstellung der Untersuchung\n"
+ "zulässig wäre. Dies gilt namentlich für die Frage, ob dem Beschwerdeführer eine\n"
+ "Verletzung der ärztlichen Sorgfaltspflicht vorzuwerfen ist. Das Obergericht hat\n"
+ "insbesondere festgestellt, dass diesbezüglich auffällige Abweichungen bestehen\n"
+ "zwischen dem schriftlichen Obduktionsbericht und den telefonischen Auskünften\n"
+ "einer Mitverfasserin dieses Berichtes gegenüber der verfahrensleitenden\n"
+ "Staatsanwältin.\n"
+ "Entgegen der Auffassung des Beschwerdeführers ist die E-Mail vom 15. Dezember\n"
+ "2015 der verfahrensleitenden Staatsanwältin (bzw. deren Notiz über die\n"
+ "gleichentags erfolgten telefonischen Auskünfte der Mitverfasserin des späteren\n"
+ "Obduktionsberichtes) im vorliegenden Zusammenhang nicht bedeutungslos. Zwar\n"
+ "bezweifelt er, ob die fragliche Ärztin des IRM solche Auskünfte überhaupt erteilt\n"
+ "habe. Seine Vorbringen lassen die Feststellung der Vorinstanz, dass aufgrund der\n"
+ "bisherigen Untersuchungsergebnisse erhebliche Widersprüche und Unklarheiten\n"
+ "bei Kernfragen der Untersuchung bestehen, jedoch nicht als offensichtlich unrichtig\n"
+ "oder sonstwie bundesrechtswidrig erscheinen (vgl. Art. 97 Abs. 1 i.V.m.\n"
+ "Art. 105 Abs. 1 BGG).\n"
+ "Dass hier (nach dem Grundsatz “in dubio pro duriore”) keine Einstellung zu\n"
+ "erfolgen hat, sondern eine gezielte Ergänzung der Strafuntersuchung, entspricht\n"
+ "den oben (Erwägungen 4.1-4.2) dargelegten Vorschriften des Gesetzes:\n"
+ "Entgegen den Vorbringen des Beschwerdeführers besteht gegen ihn ein hinreichender\n"
+ "Tatverdacht der fahrlässigen Tötung durch pflichtwidriges Untätigbleiben.\n"
+ "Seine Straflosigkeit ist nicht schon deshalb erstellt, weil die Patientin und ihre\n"
+ "Angehörigen sich (nach der hausärztlichen Behandlung) trotz weiter bestehenden\n"
+ "Schmerzen nicht mehr am gleichen Tag bei ihm gemeldet hätten. Für die hier\n"
+ "gebotene gutachterliche Abklärung eines strafbaren Diagnose- und/oder Behandlungsfehlers\n"
+ "des Hausarztes am Morgen des 14. Dezember 2015 erscheint das\n"
+ "anschliessende Verhalten der Patientin und ihrer Angehörigen nicht von ausschlaggebender\n"
+ "Bedeutung: Aus den bisherigen Untersuchungsergebnissen ergibt\n"
+ "sich (wenn überhaupt) kein derart hohes Selbst- oder konkurrierendes Drittverschulden,\n"
+ "dass der adäquate Kausalzusammenhang zwischen einem Diagnoseoder\n"
+ "Behandlungsfehler des Hausarztes und dem Tod der Patientin ohne Weiteres\n"
+ "als unterbrochen anzusehen wäre (vgl. dazu BGE 135 IV 56 E. 2.1 S. 64 f.; 131\n"
+ "8\n"
+ "IV 145 E. 5.2 S. 148; 130 IV 7 E. 3.2 S. 10 f., E. 6.2 S. 19; 126 IV 13 E. 7a/bb S.\n"
+ "17; je mit Hinweisen).\n"
+ "Die Ansicht der Vorinstanz, eine Straflosigkeit des Beschwerdeführers sei noch\n"
+ "nicht mit genügender Wahrscheinlichkeit erstellt, insbesondere sei im Untersuchungsverfahren\n"
+ "gutachterlich spezifisch abzuklären, ob das Verhalten des\n"
+ "Hausarztes, darunter sein Verzicht auf eine notfallmässige Einweisung der Patientin\n"
+ "in ein Spital, den massgeblichen Regeln der ärztlichen Kunst entsprochen\n"
+ "habe, hält vor dem Bundesrecht stand (Art. 308 Abs. 1 i.V.m. Art. 182 ff. und\n"
+ "Art. 319 Abs. 1 lit. a-b StPO).\n"
+ "6.\n"
+ "Die Beschwerde ist abzuweisen, soweit darauf einzutreten ist.\n"
+ "Die Gerichtskosten sind dem Beschwerdeführer aufzuerlegen (Art. 66 Abs. 1\n"
+ "BGG). Er hat der anwaltlich vertretenen privaten Beschwerdegegnerin ausserdem\n"
+ "eine angemessene Parteientschädigung zu entrichten (Art. 68 BGG); diese wird\n"
+ "auf (pauschal) Fr. 2’500.– festgelegt.\n"
+ "Demnach erkennt das Bundesgericht:\n"
+ "1.\n"
+ "Die Beschwerde wird abgewiesen, soweit auf sie einzutreten ist.\n"
+ "2.\n"
+ "Die Gerichtskosten von Fr. 3’000.– werden dem Beschwerdeführer auferlegt.\n"
+ "3.\n"
+ "Der Beschwerdeführer hat der privaten Beschwerdegegnerin eine Parteientschädigung\n"
+ "von Fr. 2’500.– (pauschal, inkl. MWST) zu entrichten.\n"
+ "4.\n"
+ "Dieses Urteil wird den Verfahrensbeteiligten und dem Obergericht des Kantons\n"
+ "Zürich, III. Strafkammer, schriftlich mitgeteilt.\n"
+ "9\n"
+ "Lausanne, 27. Februar 2017\n"
+ "Im Namen der I. öffentlich-rechtlichen Abteilung\n"
+ "des Schweizerischen Bundesgerichts\n"
+ "Der Präsident: Merkli\n"
+ "Der Gerichtsschreiber: Forster\n"
+ "10";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}