#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<![,\.]\d*?)(?<=\d)(?=(?:\d{3})+(?!,)\b)"
Local $sString = "123" & @CRLF & _
".123456" & @CRLF & _
"12.12345" & @CRLF & _
"123.12345" & @CRLF & _
"1234.1234" & @CRLF & _
"7777777" & @CRLF & _
"111111.1" & @CRLF & _
"65432.123456 65665.66 5544433,777665 4456677" & @CRLF & _
"123456789" & @CRLF & _
"12345." & @CRLF & _
"12312312312312345.123456789" & @CRLF & _
"123,456" & @CRLF & _
"12345555666,489" & @CRLF & _
"12,345,678.12"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)