import re
regex = re.compile(r"endpointKeyHash\":\{\"string\":\"(?<endpointKeyHash>[^\=\"]*)")
test_str = "2641328 [EPS-log-dispatcher-11] INFO 1.24978294676695149906 - {\"Log Header\": \"{\"endpointKeyHash\":{\"string\":\"MAz7MadOhr02tPt5vtZsSEy9FWw=\"},\"applicationToken\":{\"string\":\"24978294676695149906\"},\"headerVersion\":{\"int\":1},\"timestamp\":{\"long\":1495594584490},\"logSchemaVersion\":{\"int\":2}}\",\"Event\":{\"temperature\":-1,\"timeStamp\":1495594583638}}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")