package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(([^()]*\bcm\b[^()]*)\)`)
var str = ` (89 g) (89 X 45 cm) (89) (89 g)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}