$re = '/\(([^()]*\bcm\b[^()]*)\)/m';
$str = ' (89 g) (89 X 45 cm) (89) (89 g)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);