using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![a-z])[<>{}""\/|;:.,~!?@#$%^=&*']|[<>{}""\/|;:.,~!?@#$%^=&*'](?![a-z])";
string input = @"don't
,my-oh-my!
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}