re = /(?<![a-z])[<>{}"\/|;:.,~!?@#$%^=&*']|[<>{}"\/|;:.,~!?@#$%^=&*'](?![a-z])/mi
str = 'don\'t
,my-oh-my!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end