import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_ga=|_wc=|_client_ip=|gid|PHPSESSIONID";
final String string = "_omappvp=S4w0ezi1jslQaydBfF7SGXnJbD5a3UQhkbGGQ2MR9hNK2HBmTI1GNULr8cgN7jkfz2GtnooYLihsSD7bwvHTXXxwYWj9QrN9; return_visitor_check=1; return_visitor=0; _ga=GA1.2.117472760.1586869894; _gid=GA1.2.810288910.1586869894; hubspotutk=4d103d36cff43f0e71eb970298258b0a; __zlcmid=xij3lx6J8wD9rA; _client_ip=96.59.34.208; _gat_UA-9874433-6=1; _dc_gtm_UA-9874433-6=1; __hstc=145555627.4d103d36cff43f0e71eb970298258b0a.1586869894072.1586875437688.1586880592167.5; __hssrc=1; __hssc=145555627.1.1586880592167\n"
+ " _gid=GA1.2.810288910.1586869894\n"
+ " _gid=GA1.2.810288910.1586869894\n\n\n"
+ "\" _gid=GA1.2.810288910.1586869894\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}