use strict;
my $str = '_omappvp=S4w0ezi1jslQaydBfF7SGXnJbD5a3UQhkbGGQ2MR9hNK2HBmTI1GNULr8cgN7jkfz2GtnooYLihsSD7bwvHTXXxwYWj9QrN9; return_visitor_check=1; return_visitor=0; _ga=GA1.2.117472760.1586869894; _gid=GA1.2.810288910.1586869894; hubspotutk=4d103d36cff43f0e71eb970298258b0a; __zlcmid=xij3lx6J8wD9rA; _client_ip=96.59.34.208; _gat_UA-9874433-6=1; _dc_gtm_UA-9874433-6=1; __hstc=145555627.4d103d36cff43f0e71eb970298258b0a.1586869894072.1586875437688.1586880592167.5; __hssrc=1; __hssc=145555627.1.1586880592167
_gid=GA1.2.810288910.1586869894
_gid=GA1.2.810288910.1586869894
" _gid=GA1.2.810288910.1586869894"';
my $regex = qr/_ga=|_wc=|_client_ip=|gid|PHPSESSIONID/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}