$re = '/(?<numbers>[0-9]+)/m';
$str = 'sjd 3232.3232.2332ssddjs/.2323.233223';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);