package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(?P<company>[^|]+?)\s*\|\s*(?P<title>[^|]+?)\s*\|\s*(?P<locations>[^|]+?)\s*(?:\|\s*(?P<attrs>.+))?$`)
var str = `Google | Software Developer | SF | REMOTE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}