re = /\s*(?P<company>[^|]+?)\s*\|\s*(?P<title>[^|]+?)\s*\|\s*(?P<locations>[^|]+?)\s*(?:\|\s*(?P<attrs>.+))?$/
str = 'Google | Software Developer | SF | REMOTE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end