import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\.)(?:\\s([A-Z\\u00C0-\\u00dd][A-Z\\u00C0-\\u00dd]*[a-z\\u00E0-\\u00ff][a-zA-Z\\u00C0-\\u00ffA-Z]*)|\\s(A|O|À)(?=\\s|\\.))";
final String string = "Usuário Não Autenticado. Contate o ADM. Em Caso De Ou O A. Vou À Bahia. UsuÁrio Não AUtenTicadO. Ok Vamos testa. Contate o ADM. O Padre joão paulo.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}