const regex = /(?<!\.)(?:\s([A-Z\u00C0-\u00dd][A-Z\u00C0-\u00dd]*[a-z\u00E0-\u00ff][a-zA-Z\u00C0-\u00ffA-Z]*)|\s(A|O|À)(?=\s|\.))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\.)(?:\\s([A-Z\\u00C0-\\u00dd][A-Z\\u00C0-\\u00dd]*[a-z\\u00E0-\\u00ff][a-zA-Z\\u00C0-\\u00ffA-Z]*)|\\s(A|O|À)(?=\\s|\\.))', 'g')
const str = `Usuário Não Autenticado. Contate o ADM. Em Caso De Ou O A. Vou À Bahia. UsuÁrio Não AUtenTicadO. Ok Vamos testa. Contate o ADM. O Padre joão paulo.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}