using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"taken:\s+(?<executiontime>\d+)";
string input = @"{ ""event"" : ""test"", ""message"" : ""OUT: IndexController.printHello - time taken: 519 ms""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}