package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)taken:\s+(?<executiontime>\d+)`)
var str = `{ "event" : "test", "message" : "OUT: IndexController.printHello - time taken: 519 ms"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}