package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(#(?<tag>[A-Za-zА-Яа-я]{1,19})\s*)+`)
var str = `#asdf #fdsa #фываолрф`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}