$re = '/-?\b(?<!\d-)\d+\b/m';
$str = 'LS022-1234-5678
FA123245
redeem: -1234
paid: 234432';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);