re = /-?\b(?<!\d-)\d+\b/m
str = 'LS022-1234-5678
FA123245
redeem: -1234
paid: 234432'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end