using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])(?=[ a-zA-Z\d-]*[^ a-zA-Z\d-])\D*\d";
string input = @"aBcD123
Aa1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}